Hardware & Software Requirements:

The below will outline our minimum requirements in order to support your business. 

Windows:

  • Processor: 1 gigahertz (GHz) or faster processor or SoC.
  • RAM: 1 gigabyte (GB) for 32-bit or 2 GB for 64-bit.
  • Hard disk space: 16 GB for 32-bit OS 20 GB for 64-bit OS.
  • Graphics card: DirectX 9 or later with WDDM 1.0 driver.
  • Display: 800×600

Macintosh:

macOS Version 10.14 Mojave

  • Compatible Macs
    • MacBook (Early 2015 or newer)
      MacBook Air (Mid 2012 or newer)
      MacBook Pro (Mid 2012 or newer)
      Mac mini (Late 2012 or newer)
      iMac (Late 2012 or newer)
      iMac Pro (2017)
      Mac Pro (Late 2013; Mid 2010 and Mid 2012 models with recommended Metal-capable graphics cards)
  • OS X 10.8 or later
  • 2GB of memory
  • 12.5GB of available storage (OS X El Capitan 10.11.5 or later)*
    • *Requires up to 18.5 GB of available storage to upgrade from earlier releases.

macOS Version 10.13 High Sierra

  • Compatible Macs
    • MacBook (Late 2009 or newer)
      MacBook Pro (Mid 2010 or newer)
      MacBook Air (Late 2010 or newer)
      Mac mini (Mid 2010 or newer)
      iMac (Late 2009 or newer)
      Mac Pro (Mid 2010 or newer)
  • OS X 10.8 or later
  • 2GB of memory
  • 14.3GB of available storage to perform upgrade*
    • * Upon completion of the upgrade, macOS High Sierra requires approximately 1.5GB more storage.

MacOS Version 10.12 (a.k.a Sierra)

  • Compatible Macs: MacBook (Late 2009 or newer), MacBook Pro (Mid 2010 or newer), MacBook Air (Late 2010 or newer), Mac mini (Mid 2010 or newer), iMac (Late 2009 or newer), Mac Pro (Mid 2010 or newer)
  • OS X 10.7.5 or later
  • 2GB of memory
  • 8.8GB of available storage

Best Effort

Mac OS X Version 10.11 (a.k.a El Capitan)

  • Compatible Macs:  iMac (Mid 2007 or newer), MacBook (Late 2008 Aluminum, Early 2009, or newer), MacBook Pro (Mid 2007 or newer), MacBook Air (Late 2008 or newer), Mac mini (Early 2009 or newer), Mac Pro (Early 2008 or newer) Xserve (Early 2009)
  • Mac OS X Mountain Lion, Lion, or Snow Leopard v10.6.8 already installed
  • At least 2GB of RAM
  • At least 8.8 GB of disk space available

Mac OS X Version 10.10 (a.k.a Yosemite)

  • Compatible Macs: iMac (Mid 2007 or newer),  MacBook (Late 2008 Aluminum, Early 2009 or newer), MacBook Pro (Mid 2007 or newer), MacBook Air (Late 2008 or newer), Mac mini (Early 2009 or newer), Mac Pro (Early 2008 or newer), Xserve (Early 2009)
  • Mac OS X Snow Leopard v10.6.8 or later already installed
  • At least 2GB of RAM
  • At least 8GB of disk space available

Software

  • Microsoft Office & Office 365 (only if you use this)
  • Java 
  • Quick Time
  • Adobe Shockwave
  • Adobe Acrobat Reader 
  • Adobe Flash Player
  • more to come.